Frustration vs Relief

It has been pretty hectic for me for the past several weeks, main reason being, my Charmant is suffering from waves and waves of annoying engine issues, even AFTER I’ve replaced my head and block!

Let’s see, where should I start…. oh alrighty then, let’s start on the day I got my car back soon after my 2nd 4AGE was installed.  The engine felt fine for the 1st couple of days, yet the startup misfiring problem was still there, my friends and I were convinced that it’s probably coming from the wiring, or it could’ve just been some other little things like the sensors, or maybe even the ECU (gulp!).  But then, I’ve been sending my car back to workshop numerous times, failing to pin-point the exact culprit, therefore it was then decided it’s best that I should just take it easy on my Charmant, unless I’m willing to screw up another 4age block that is, LOL!

Like I’ve said, the 1st couple of days were fine, soon after I brought the car to a random drift session on a sunny weekend afternoon, the car overheats, in like, just 2-3 donuts!  I then proceeded to service my radiator, but soon found out that the problem was not only from my old rusted out radiator, but it was also due to the worn out head gasket, then to add to my misery, the engine also had oil leaks, grrr!

Worn head gasket

TVIS

CAMS and etc

Ugh...

I’ve replaced the gasket with the TRD metal gasket from my previous 4AGE (don’t ask why I didn’t use it back then, coz I never knew it was TRD till Louis REMINDED me… LOL!!), also had the 4AGE head re-skimmed so the surface will be smooth again, this also means that my compression has increased slightly higher (hehe!).  To resolve the oil leak problem, 3 seals were replaced.  After all were done and everything put back in place, the engine just doesn’t sound right, first of all, its still misfires randomly during crank startups, once the engine is fired up, it is now jerking whenever throttle is applied.  This is when my frustration started to build up….

The mechanic wasn’t quite sure what was the problem, neither do I (d’oh! OBVIOUSLY!), but somehow he decided to have a look at my ECU, and to our horror, several of the ECU’s capacitors are f*cked!  I’m like “How the F*CK does that happen?!”  I’ve started making calls to those that are more familiar with 4AGE, and they told me its something easy to fix since its just my capacitors, instead of those chips (phew! speaking of lucky…).  My ECU was then brought to an electrical shop for repairs, the shop have serviced many types of ECU before, so I trust their experience, but I don’t know how much they’ll ‘cut’ me afterwards, this is just a moment when you are basically vulnarable any type of free slaughtering.. T_T

Weeks past, ECU fixed, and just when we thought the engine would now run fine… the problem was still there!  I’ve started to panic and feared for the worst, I mean, c’mon, I’ve literally changed my whole engine, service a whole bunch of little stuffs here and there, including my ECU, what else of a problem could there be!?

The ECU was sent back again for another closer inspection, but once it was re-installed to my Charmant, there was no success in rectifying the ever annoying misfiring and jerking issues.  When I almost lost hope, I got a call from Johnny..

“Stan, how’s your car?”

“Not done, not sure if the Mech can resolve or not, real headache now”

“Tomorrow I go have a look”

On the next day, I went and have another look on my poor Charmant and also said Hi to Johnny as he just came back from Miri.  When I reached there, he and the mechanic were already digging their way into my Charmant, they were having a check on my wiring setup:

The mech and Johnny

Checking for any faulty wires

Ill 4AGE

My miserable ECU

On the first day that Johnny decided to check on my car, both he and the mechanic had made sure that there was nothing wrong with my engine wires, they’ve also replaced all the sensors, the throttle body, the ignition coil just to see if those help, but to no avail.  It was definitely uncomfortable to see that a 4AGE freak like Johnny, would get frustrated by my car too! XD

Anyways, as a 4AGE freak that Johnny is, he wasn’t going to give up so easily, he then teamed up with the mechanic, and spent 2 FULL days on my car, he even dropped by my house and got a copy of the 4AGE manual (in pdf) since he forgot to bring his from Miri so he can study them thoroughly at home, that’s commitment over there!

On last Saturday, I got another call from Johnny…

“Stan, you coming to check on your car later?”

“uh.. yeah of course, how’s it now?”

“Your car can throw away already la~”

“……”

“Just come and see for yoursel, hehe”

After I finished my work, I immediately drove to the workshop to meet up with Johnny and the mech, both of them were chilling out at a nearby coffee shop, with some other customers, they were all chit chatting about cars and etc.  I sat down, and Johnny and the mech both looked as if there’s nothing happened, I was nervous, because I really wanted to know what’s the outcome of my car!

When the customer finally left, I popped my question:

“Eh, so how’s my car ah?”

“Can throw already”

“C’mon~ seriously!?”

“Haha, well… why don’t you go test drive it first and see for yourself?”

“uhm…. ok…”

I took the keys, walked towards my Charmant, crank started the engine, “Vroooom!” perfect start on 1st try!  I shut it off and crank started it again, another good start!  Engine sounds normal, I then decided to put it in 1st gear and just drove away to see how it feels.  1st, 2nd then 3rd and off I go, zooming along the nearby streets, it was great feeling, the engine felt good, just like the time when I first drove my car out of the workshop when it first had a 4AGE installed!

After the test drive, I walked towards the coffee shop again, they were still chilling, when I asked what and how they did it, both of them just grin at me, I didn’t know what to say, but I just had to laugh, I then sat down again and we all had another drink.

I was then told by Johnny that the main culprit was in fact, coming from my wires, the wires are all good, but there was one socket coming from my ignitor, had the wires wrongly connected!

WTF wire job!

You can see it’s a total mess in there, noticed the yellow socket? It wasn’t put in good use though, as some of the wires have connected without going through the socket, I’m not very good at explaining the details, but somehow it goes like this, let’s say I have 2 set of wires, 1 red 1 blue, and then at the other end, there’s also 2 wires, 1 red and 1 blue.  You might think the red one should go with the red while the blue to the other blue, but it just doesn’t work like that, I don’t know why, but it’s actually the other way around.  Now how the heck did that happened?  Well, long ago when I had my oil changed at this particular friend’s shop, my car couldn’t start, that mechanic (my friend as well), obviously didn’t knew what he was doing, decided to mess around with my already messed up wires, and somehow he just made the worst move, by relocating my wires, while replacing my plugs at the same time, the wiring job done by him didn’t cause any noticeable effect, but the plugs were the one that made the car starts again, while I thought he saved the day, he actually made me and my Charmant’s life much… much more miserable for the next few months!

Because of his messed up wiring job, I’ve almost burnt my entire ECU, and if Johnny hadn’t located the problem, I might just have blown another 4AGE in no time!  All in all, Johnny is yet again, my hero that saved the day!  He told me…

“Stan, I had to literally pull out ALL the wires from your 4AGE, and check on them 1 by 1, after this, I think I can do a 4AGE wire job from scratch now!”

LOL!!

Seriously, I just couldn’t imagine how much damage and $$ I have to spend if Johnny didn’t came by to help, the mech might just ask me to change this, change that, buy this and replace that, at the end I will just be so broke I won’t be able to take care of my dearest Charmant again.

I owe Johnny big time, and I’ll be sure to treat him on a big one very soon!  For me personally, I’m just glad that my 4AGE is now perfectly normal, I can crank start it 10 times and it still wouldn’t give me any of those misfiring crap!  I felt relieved that’s for sure, now let’s hope the bill won’t come up too shocking! -___-

Advertisements

3 Responses to “Frustration vs Relief”

  1. Wow! I’m glad for you it worked out fine in the end…!! 😀

  2. charmant still giving u a headache? thats pretty damn

  3. Louis and Kev: Looks like my 4AGE problem hasn’t come to an end, the engine seems to ‘hesitate’ during high rev, not sure what that is, man… have to diagnose…again!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

%d bloggers like this: