Double One!

Double one = 11 = Eleven = November

Get it?

………

Ok, that was lame!  Sorry!

Anyways, back on topic, my Charmant is finally at home, engine is running smooth, but the startup hiccup issue is still there, replaced and tested almost anything possible for the tiny 4AGE, but to no avail, the only thing left unchecked would be the wiring, but I’ve decided to just leave it as it is for the time being.

Overall, I had the following replaced:

  1. 4AGE block
  2. Spark plugs
  3. 1 Plug cable
  4. Fuel pump
  5. Air cond hose (Yes, my air cond is back, finally!)

I’m glad the car is running fine, but there are some annoying sounds coming from my extractor, after a quick checkup, there’s a tiny crack leak going on there, again I’m currently out of budget so it’ll just have to be left as it is for the time being.

Another disappointment is that my rear E-brake is still not repairable, the only solution is to get another spare axle, so…. yeah, that will have to wait too!

Anyhow, been driving the Charmant for 2 days now, had a test drift at my usual playground and the car overheats!  Haven’t got the time to send it back to the workshop for checkup till today, so wish the Charmant luck!  I can’t wait to burn more tires!

 

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

%d bloggers like this: