Archive for February 21, 2009

Thermostat

Posted in Car stuff on February 21, 2009 by Stanley Carter

Believed it or not, my 4AGE doesn’t has a thermostat installed!  Thanks to my mechanic, who actually took it out and threw it away, well its because he has this weird belief that thermostat does nothing good but fucks up the engine, hmmm… WTF?

Anyhow, I ordered a thermostat from a local spare parts shop, suited for all 4A engines:

4A Thermostat

4A Thermostat

The thing costs me RM52, ok ok la…

4A Thermostat

4A Thermostat

Other than the thermostat, I’ve also bought some gasket sheets and gasket glue for the installation use.

The next day, I’ve called up Johnny and he dropped by my house at night to help me with the installation, he was doing all the work while I was learning in the process (I’m a mechanical idiot).  Turns out that the installation process of the thermostat is extremely easy, LOL!

Unscrewing

Unscrewing

No thermostat

No thermostat

The above pictures were taken before the thermostat was installed, Johnny placed the new thermostat that I bought in the hose and put everything back into place again.  We’ve started the engine, refilled the radiator water and waited for the results, unfortunately, the thermostat FAILED us.  When the water temp started rising above optimum level, the thermostat wasn’t opening up its valve, which caused the engine to increase heat since water was blocked and not flowing.

Long story short, I’ve returned the thermostat to the shop and asked for a replacement, which I did just few days later.  Although I got the replacement thermostat already, I have yet to install it onto my 4AGE, blame that on my laziness I guess  LOL!  However, when I do have the time, I’ll be doing it by myself for sure, big thanks to Johnny for all the help earlier!

Advertisements